Pivot and Stykz

What's the Same? What's Different? What's Missing?

Last updated on 10/16/2010

Stykz was designed to be a superset of Pivot, and in fact it does almost everything that Pivot does plus a whole lot more. However, there are a few things that Pivot currently does that Stykz does not, and there are things that Stykz does differently than Pivot but with the same end result.

You can see a quick comparison of Stykz vs. Pivot on the Stykz website, but here's a more specific rundown on how the two compare. This page is intended primarily for Pivot users who are looking at Stykz and wondering what skills can be leveraged, and what needs to be relearned, and what can't be done (yet).

Creating Animations

Both Pivot and Stykz use frame-based animation and display each frame as a thumbnail image. Both applications use the Enter key to go to the next frame or create a new frame (if you're on the last frame), and both even allow you to use the Enter key while dragging a figure or pivoting a segment to quickly create frames of an animation.

Pivot uses a default stage size of 506x415 (Pivot 2) or 505x425 (Pivot 3). Stykz has a default stage size of 700x500, although you can change the default size in Preferences (Edit* > Preferences >> General > New Document Settings > Stage Size)

Navigation in Stykz and Pivot is the same (click on a frame box in the list of frames), but Stykz also lets you navigate to a specific frame by dragging the "scrubber" slider on the Controller Palette:

Stykz is different than Pivot in the way the thumbnails in the Frames Palette are displayed. In Pivot, you don't see the current frame's thumbnail updated until you go to another frame or hit the Next Frame button. Stykz automatically updates the thumbnail as soon as any changes are made to the current frame. Because of this, you don't need to make an "extra" frame or click on some other frame in order to see your thumbnail update.

Creating Figures

Creating figures from scratch is very different in Stykz than in Pivot:

In Pivot, to create a new figure, you need to go into a separate window (the Stick Figure Builder), and then select a line or circle to add, click, if it's not the right length you need to be in Edit Mode to make the changes, and then there's a lot of click-click-click to build your figure in isolation (you can't see how it looks against the rest of the figures on the stage yet). When you think you're done, you add the figure to the stage. If you made a mistake, since you can't edit the figure you just made, you need to create a new figure based on the selected one, change it, add it to the stage and then delete the "bad" one from the stage.

In Stykz, you create figures directly on the stage using one of two methods: you can use the Add Line and Add Circle tools in a similar fashion to Pivot, or you can use either the Select or Subselect tools and simply right-click where you want a segment to start and drag and release where you want it to end (see Creating a Figure From Scratch).

You can also select from a set of predefined figures (including a version of the Pivot 2 figure) as a starting point by choosing from the Figure menu.

Manipulating Figures

You can manipulate figures on the Stage in Stykz the same way as in Pivot: click on the yellow drag node to move the figure; click on a red node to pivot a segment and any attached segments.

But Stykz goes farther and gives you more options. You can turn on a preference that will allow you to drag a figure not only by the drag node but also by any part of the figure that is not a pivot node if you wish (Edit* > Preferences >> Nodes/Segments > Node Options > Can only move figure using drag node).

You can also stretch or distort a segment by holding down modifier key(s) while dragging on a node (see Manipulating Figures), and you can add a node to a segment or remove a node from a segment (see Adding/Deleting Nodes), or even delete a segment completely from a figure (See Adding/Deleting Segments).

You can also fill regions inside of a figure using Stykz's PolyFill Tool (instead of using up precious segments in Pivot for filling an empty region).

With the Select tool, you can select multiple figures to manipulate, and with the Subselect tool, you can select multiple segments.

As in Pivot, you can move a figure to the front or back of the stacking order, but you can also move selected figure(s) forward or backwards one layer, and you can do the same to selected segments (see Adjusting Figure/Segment Layering). You can also scale and rotate figures on the stage.

Static and Hidden Segments

You can make segments static like in Pivot, but it's done a little differently. Static segments don't need to be defined as static when they are created (like in Pivot); instead you simply need to select the segment(s) you want to make static using the Subselect tool and check the "Static" checkbox in the Segment Properties palette.

You can hide segments too, but instead of setting the thickness of a segment to 0 as you would in Pivot, you just have to check the "HIdden" checkbox in the Segment Properties palette.

For more information on this and other segment properties, see Setting Segment Properties.

Frame Backgrounds

One of the main differences between Stykz and Pivot is that Pivot can work with bitmap images, and can load a background that is an image for use on the current frame. Stykz currently does not support importing images for backgrounds, but you can set the background color to a selected solid color through use of the Stage Properties palette, but be aware that the color applies to all the frames in the animation.


Pivot can import sprites, and Pivot 2/Pivot 3 Stick files (.stk). Stykz cannot import sprites yet, but it can import and convert Pivot 2 and Pivot 3 .stk files by choosing File > Import Pivot .stk File.

Since Pivot and Stykz have different means of managing and drawing figures, there are some figures that were created in Pivot that don't translate completely into Stykz. For more information, see Notes on .stk Compatibility.


Both Pivot and Stykz can export animations to Animated GIF format (in Stykz choose File > Export Animation...), and Pivot and Stykz can export a sequence of images (Pivot 2 can do Bitmap, Pivot 3 can do Bitmap, JPEG and GIF, and Stykz can do PNG or GIF). Additionally, Stykz can export a sequence of images as transparent PNGs and can also export to QuickTime format. This format is very useful, especially when you want to upload an animation to YouTube.


Node Layering

Pivot shows the nodes for all figures in their own layer in front of the actual figures; Stykz does this too, but also gives you the option (through View > Show Nodes In Front) of keeping the nodes with the figure they're attached to so you can better see which nodes belong to which figure:

By default, this is set to checked (TRUE) for Pivot compatibility, but there can be times when you might want to uncheck it to see the layering. (For more detail, see Node Layering.)


Pivot draws all of its segments in an aliased (jagged) form; Stykz by default will draw segments antialiased (smooth), but if you are using Windows, you can choose to use aliased instead, or change it on the fly as you like. You can toggle this back and forth by choosing View > Show Antialiasing. If you want to change it permanently, you can do that in Preferences (Edit* > Preferences >> Nodes/Segments > Segment Options > Show segments aliased (Windows only))

Pivot Compatibility Option

If you want to make Stykz act as close to Pivot as possible, you can turn on the "Pivot Compatibility" option in Preferences (Edit* > Preferences >> Pivot Compatibility > Pivot Stickfigure Animator Compatibility > Change Settings) which will set various behaviors and properties to match Pivot as closely as possible.

Community Support

Since Pivot and Stykz are so similar, the Pivot community is great for getting animating tips, feedback on your skill level, and even to get ideas or just have a great discussion about a topic of interest. The two main Pivot sites out there are DarkDemon.org and Droidz.org, so if you're not currently a member, you should consider joining one or both of them (along with joining the Stykz forums, of course).